MS Azure Front Door outage
Resolved
Oct 29 at 11:38pm CET
All services are now fully operational. Due to global Microsoft network issues, our services were unavailable between 16:45 and 21:25 CET.
We would like to apologize for any inconvenience caused.
Affected services
Updated
Oct 29 at 08:35pm CET
At 8:31 p.m. CET, services are recovering. It may take a little longer in some regions until everything is accessible again.
Microsoft restored the last valid configurations, thereby restoring services. We are awaiting the root cause analysis from Microsoft.
Here's the full statement:
"We initiated the deployment of our ‘last known good’ configuration, which has now successfully been completed. Customers may have begun to see initial signs of recovery. We are currently recovering nodes and routing traffic through healthy nodes, and as we make progress in this workstream, customers will continue to see improvement.
Customer configuration changes will remain temporarily blocked while we continue mitigation efforts. We will notify customers once this block has been lifted.
Some customers may also have experienced issues accessing the Azure management portal. We have failed the portal away from AFD to mitigate these access issues. Customers should now be able to access the Azure portal directly, and while most portal extensions are functioning as expected, a small number of endpoints (e.g., Marketplace) may still experience intermittent loading problems.
At this stage, we anticipate full mitigation within the next four hours as we continue to recover nodes. This means we expect recovery to happen by 23:20 UTC on 29 October 2025. We will provide another update on our progress within two hours, or sooner if warranted.
Although we are seeing signs of recovery and have an estimated timeline, customers may also consider implementing failover strategies using Azure Traffic Manager to redirect traffic from Azure Front Door to their origin servers as an interim measure."
Affected services
Updated
Oct 29 at 06:39pm CET
We do not have an Estimated Time of Arrival (ETA) for when the services are online again, but we will update this communication when we receive further information from Microsoft.
Microsoft is working on this issue as a matter of the highest priority.
Affected services
Created
Oct 29 at 06:06pm CET
From approximately 16:00 UTC onwards, we started to experience issues with Azure Front Door, resulting in some services becoming unavailable. Consequently, customers may have difficulty accessing our platform.
More information on the global MS Azure outage can be found here:
https://azure.status.microsoft.com/de-de/status.
Affected services